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This chapter describes how to set OZ Server, Repository server, Cache, Connection, Log,

Monitor log by using OZ Enterprise Manager.
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Click [Console] > [New Server] in the Menu bar, or [New Server] in a pop-up that appears

after right-clicking on the left Console list window, or click on the New Scheduler icon to add a

new server.

Entering each item in the "New Server" dialog box and clicking on [Add] will display the added

server under the [Server List] of the [Console List]. 

From the console list window by clicking the right mouse button on the "server list" [New

Server] from the pop-up menu that appears when you click the menu "New Server" dialog box

appears.
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Name : Type the OZ Server name.

Type : Set the OZ Server type.

TCP : Set the OZ Server to daemon type.

HTTP : Set the OZ Server to servlet type.

IP : Set the OZ Server IP.

If the OZ server type is set to TCP use.

Port : Set the OZ Server Port.

If the OZ server type is set to TCP use.

URL : Set the OZ Server URL.

If the OZ server type is set to HTTP use.
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Open a pop-up by right-clicking on the server to log in the Server List, and click on [Connect] to

open up the "Login" dialog box.

With admin privileges on the "Login" dialog box, enter the user ID and password, and then

connect to the server and click the [OK] button. When the connection to the server is

complete, icons and menus that can manage the server is displayed in the toolbar and console

menu.
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[Management] in the console menu using the menu you can check Server Information, Server

License, Memory Status, and you can run Memory Collection, Stop Server, Restart Server.

Click on the menu of the console [Management] > [Server Information] menu

The server version, operating system, host name, etc of the information is displayed in the

Properties window.
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Click on the menu of the console [Management] > [Server License] menu

Product, version, operating system, IP, etc, server license information is displayed in the

Properties window.

To apply the licenses without server restart, after you copy the license file(ozlicense.xml) in the

license folder, please click the [Activate license] button at the bottom of the window. 

If you want to apply a license using the [Activate license] button all the license keys are not

applied, apply only the key below.

· MAX-CLIENT

· USE-EFORM

· USE-SERVERBIND

· USE-WEBSERVICE

· REQUEST-URI

Click on the menu of the console [Management] > [Memory Status] menu

Is displayed in the Properties window of the server operating system the Total Memory, Used

Memory, and Free Memory.



Copyright ©  FORCS Co.,LTD. All rights reserved.

Tools
User Guide for OZ Enterprise Manager

9

Note :

From the server and the server indicates that a running application that uses memory.

Click on the menu of the console [Management] > [Memory Collection] menu

Replaced by the memory available by removing the memory that the server did not use the

memory to run a collection job.

When you click the [Memory Collection] menu the Properties window is displayed as

previously properties window.

Click on the menu of the console [Management] > [Stop Server] menu
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Displays a dialog box asking whether the server stops.

When you click the [OK] button, the server stop.

Note :

The Stop Server option is enabled only in a Daemon type server.

Click on the menu of the console [Management] > [Restart Server] menu

Displays a dialog box asking whether the server restarts.

When you click the [OK] button, the server restart.

Note :
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The Restart Server option is enabled only in a Daemon type server.
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Using the [Repository] menu of console menu, setting the behavior environment of  the

repository server, and restart the repository server.

Click on the menu of the console [Repository] > [Repository Configuration] menu

Repository type, path, period of history, repository server information is displayed in the

Properties window.

To change the behavior environment of the repository server Double-click the value that you

set in the bottom of the Properties window, click the [Save] button to save, Click the Console

menu [Repository] > [Reload Repository] the menu.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "repository.properties" please. 
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Click on the menu of the console [Repository] > [Reload Repository] menu

Restart the repository server.

When you click [Reload Repository] menu the Properties window is displayed as previously

Properties window.
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Setting up cache using the [Cache] menu of the console menu check the cache list.

Click on the menu of the console [Cache] > [Cache Configuration] menu

Cache storage path will be displayed in the Properties window.

If you want to change the cache stored path after setting the path by double-clicking on the

value in the bottom of the Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "cachemngr.properties" please.
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Click on the menu of the console [Cache] > [Cache List] menu

Cache List will be displayed in the Properties window.

Double click on the cache ID to add or select [Add] after a right-click, then the "Cache

Information" dialog box will appear for editing cache information.

After enter the Cache ID, Cache Enable, Memory Cache Using Time, Free Memory Percentage

from the "Cache Information" dialog box when you click the [OK] button, the cache is added.

Double click on the cache ID to add or select [Add] after a right-click, then the "Cache

Information" dialog box will appear for editing cache information.
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Cache ID : Shows the ID to cache.

Can be entered directly or [...] button that appears

when you click the cache ID using the wizard to set.

Cache Enabled : Sets the cache is functioning.

TRUE : Activates the cache.

FALSE : Cache does not work.

Memory Cache Using Time : Sets the time in which cache remains valid in the

memory.

Disk Cache Using Time : Sets the time in which cache remains valid in the

disk(unit:sec).

Free Memory Percentage : Caches to the disk when the memory size is smaller

than the designated percent.

Clicking the Wizard button [...] in the "Cache Information" dialog box will run the "Cache ID

Wizard" as shown below.
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Cache ID : Set the Cache ID.

Entered directly or cache types and cache select a

destination will be entered automatically.

Cache Type : Selects the type of cache item.

Repository item : Creates cache ID of repository

item.

Report data module : Creates cache ID of report data

module item.

Select an object to cache : Selects the cache target.

Add Cache ID : Set the cache id for more information.
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Enter the additional information only in the report

data module.

Cache ID Adding input options set rules :

Setting option cache ID Adding input rules are as follows :

If you choose to report data module

datamodule.report.[CategoryName].[ItemName].[FetchMode]

.[ParameterName_1 = ParameterValue_1]

        ...

.[ParameterName_n = ParameterValue_n]

.[DataSetName_1 = MaxRow_1]

        ...

.[DataSetName_n = MaxRow_n]

.[InvalidSetName_1]

        ...

.[InvalidSetName_n]

ex)

datamodule.report.[/].[Sales.odi].[DM_BATCH_FETCH]

.[Region="Seoul"]

.[Year=2011]

.[DataSet_1=100]

.[DataSet_2=100]

.[DataSet_3]

.[DataSet_4]

For an explanation of each option follows.

· datamodule.report : Set the cache type whether report datamodule.

· CategoryName : Set the category name.

· ItemName : Set the data module name.

· DataSetName : Set the dataset name.

· DataSetNumber : Set the dataset number.

· FetchMode : Set the fetch mode. Set to the value of one of the

DM_BATCH_FETCH or DM_CONCURRENT_FETCH.

· ParameterName_# = ParameterValue_# : Sets the value of the parameters

have been added to the data module.

· DataSetName_# = MaxRow_# : Set the max row number of data set.

· InvalidSetName_# : Not to use the data set name.
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· MasterDataSetParameterName_# = MasterDataSetParameterValue_# : Set

the parameter values of the master dataset necessary for the binding to the

detail dataset.

Edit

From the pop-up menu that appears by right-clicking on the cache list in the Properties window

to modify the cache Running "Cache Information" dialog box by clicking the [Edit] menu.

After the change from the "Cache Information" dialog box whether the cache behavior,

memory/disk cache usage time, free memory percentage Click the [OK] button.

Delete

From the pop-up menu that appears by right-clicking cache delete cache list in the Properties

window, When you click the [Delete] menu displays a dialog box asking whether to delete.

Click the [OK] button.
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Delete Cached Data

Cache data delete in the cache list properties window by clicking the right mouse button pop-

up menu that appears When you click the [Delete Cached Data] menu displays a dialog box

asking whether to delete.

Click the [OK] button.
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Using the [Connection] menu of console menu, setting the DB, SAP connection pool.

Click on the menu of the console [Connection] > [DB Connection Pool] menu

Double-click on a connection or select [View Details] after a right-click to see the detailed

information of the connection.
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By right-clicking on the DB Connection Pool Properties window from the pop-up menu that

appears, click the [Add] menu, run "DB Connection Pool" dialog box.
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Go to the [Pool], [Connection], [Driver], [Option] tab in "DB Connection Pool" dialog box after

setting the option DB connection pool is added when you click the [OK] button.

By right-clicking on the DB Connection Pool Properties window from the pop-up menu that

appears, click the [Add] menu, run "DB Connection Pool" dialog box.

Pool
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set the DB connection pool name, Vendor type, Connection information.

Name : DB connection pool name.

DB Vendor : DB vendor type.

DB Server IP Address : DB server IP address.

DB Server Port Number : DB server port number.

DB Server Name : DB server name.

If Oracle the server distinguished name of SID  is set to

please.

User Name : Access to the DB server user name.

Password : Access to the DB server user password.

Confirm : Re-enters the password.
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Connection

Set the DB Connection number, Timeout, SessionQuery.

Max : Maximum of DB connections OZ server can have.

Init : Number of OZ server’s initial DB connections.

Connection Timeout : Maximum time for the connection used to be returned when

it exceeds the Maxconns(unit: second).

Query Timeout : Maximum time for the query execution(unit: second).

SessionQuery : Session query to set in the OZ server db.properties.
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Driver

Set the Use Driver Configuration, Driver information.

Use Driver Configuration : Sets whether to use the Driver configuration.

Driver : Driver class name.

URL : Driver connection URL.

Property : Driver connection property.

Option
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Set the Test connection, Time, Encoding/Decoding Set, JDBC Fetch Row, Ignore query error.

Attempt test connection : In case of OZ server losing connection pool, this adds

queries to test and checks the connection to the DB

when connecting to OZ server. If the connection is lost,

this reconnects the connection pool.

MinTime : Minimum time to check the DB Connection(unit:

second).

MaxTime : Maximum time to check the DB Connection(unit:

second).

Encoding char set : Encoding character set.

Decoding char set : Decoding character set.
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JDBC FETCH ROW : When return a result set setting the number of rows

that can be imported at once.

Ignore query errors : Sets whether to send empty data when an query error

occurs

Edit DB Connection Pool

Revises the connection pool by clicking on [Edit] in the pop-up that appears after right-clicking

on the connection pool to edit.
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Go to the [Pool], [Connection], [Driver], [Option] tab in "DB Connection Pool" dialog box,

after you change the options click the [OK] button.

Delete DB Connection Pool

Select a connection pool to delete, right click on it, and click on [Delete].

Click the [OK] button.

Click on the menu of the console [Connection] > [SAP Connection Pool] menu

SAP Connection Pool list will be displayed in the Properties window.

Shows the list of SAPs currently connected to the server. You can double-click on a name or

select [View Details] after a right-click to view the detailed information of a SAP.
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Using the [Server Properties] menu of console menu, setting the Databind, User Defined Log,

Data Source, User Security Logic, Mail, Information Security, HTML5MANAGER Configuration.

Click on the menu of the console [Server Properties] > [Databind Configuration] menu

Data binding related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :
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For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "databind.properties" please.

Click on the menu of the console [Server Properties] > [User Defined Log Configuration]

menu

User defined log related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "ozudl.properties" please.

Click on the menu of the console [Server Properties] > [Data Source Configuration] menu
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Data source related properties will be displayed in the Properties window.

Right-clicking and clicking on [Add] will open "Add Data Source" dialog box.

After entering configuration information in the "Add Data Source" dialog box, click on [OK] to

add the data source.
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By right-clicking on the Data Source Properties window from the pop-up menu that appears,

click the [Add] menu, run "Add Data Source" dialog box.

Alias : Data source alias name.

Data Source Type : Data Source Type.

For a detailed description of the this option, "OZ Enterprise

Server Administrator's Guide", "datasource.properties"

please.

Edit Data Source

Select a data source to edit, right click on it, and click on [Edit] to open the "Modify Data

Source" dialog box. 
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After editing the configuration information in the dialog box, click on [OK] to apply. 

Delete Data Source

Select a data source to delete, right-click on it, and click on [Delete] to delete the data source.

Click on [OK].

Click on the menu of the console [Server Properties] > [User Security Logic Configuration]

menu



Copyright ©  FORCS Co.,LTD. All rights reserved.

Tools
User Guide for OZ Enterprise Manager

35

User security logic related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "uslmngr.properties" please.

Click on the menu of the console [Server Properties] > [Mail Config] menu

Mail related properties will be displayed in the Properties window.

Shows the currently set mail information in a list and allows you to see the details by double-

clicking on each name or right-clicking and selecting [View Details].
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Right click and click on the [Add] to open "Add Mail Config" dialog box.
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After entering information in the dialog box, click on [OK] to add the mail information.

Right click and click on the [Add] to open "Add Mail Config" dialog box.
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Alias : Input the mail account alias.

active : Whether or not to activate of Mail account.

For a detailed description of the account option, "OZ Enterprise Server

Administrator's Guide", "mail.properties" please.

Edit Mail Config

Select the mail configuration to edit, right-click, and click on the [Edit] to open "Modify Mail

Config" dialog box. 
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After editing configuration information in the dialog box, click on [OK] button to confirm.

Delete Mail Config

Select the mail configuration information to delete, right click, and click on [Delete] to delete it.

Click on [OK].

Click on the menu of the console [Server Properties] > [Information Security Configuration]

menu
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Information security configuration related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "spmgr.properties" please.

Click on the menu of the console [Server Properties] > [HTML5MANAGER Configuration]

menu

HTML5 related properties will be displayed in the Properties window.
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Shows the currently set HTML5MANAGER information in a list and allows you to see the details

by double-clicking on each name or right-clicking and selecting [View Details].

Right click and click on the [Add] to open "Add HTML5MANAGER" dialog box.
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After entering HTML5MANAGER information in the dialog box, click on [OK] to add the

HTML5MANAGER.

Right click and click on the [Add] to open "Add HTML5MANAGER" dialog box.
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Alias : Set the alias of Scheduler Server.

active : Set whether to use the OZ Scheduler.

html5manage

r_ip :

Set the OZ Scheduler IP address.

html5manage

r_port :

Set the OZ Scheduler port number.

serverURL : Set the URL of the OZ server, which creates report images when

executing the HTML5 viewer.

Edit HTML5MANAGER

Select the HTML5MANAGER configuration to edit, right click on it, and click on [Edit] to open the

"Modify HTML5MANAGER" dialog box. 
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After editing configuration information in the dialog box, click on [OK] button to confirm.

Delete HTML5MANAGER

Select the Scheduler Server information to delete, right click, and click on [Delete] to delete it.

Click on [OK].



Copyright ©  FORCS Co.,LTD. All rights reserved.

Tools
User Guide for OZ Enterprise Manager

45

Using the [Log] menu of console menu, setting the log, checking saved log.

Click on the menu of the console [Log] > [Log Configuration] menu

Log related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "log.properties" please.
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Click on the menu of the console [Log] > [View Log - Realtime] menu

If you click the Properties window from the [Start] button, the contents of the log are displayed

in real-time.

To stop real-time view log, and click the [Stop] button, click the [Thread Dump] button to check

the thread dump.

Click the [Search] button after entering the text you want to search for in the text box next to

the search option to search the contents of the log. Order to retrieved content is displayed,

when you are double-click focusing searched the contents of the log.
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Click on the menu of the console [Log] > [View Log - File] menu, verify the log contents of

files stored or the log file can be downloaded.

Open Log Fi le

Click the [...] button next to the "Open Log File" in the Properties window, "Open Log File"

dialog box that appears, double-click on the file to check the logs.
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In the selected file displays the stored log contents.
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Open Log File from the contents can be searched, search method, please refer to the "log-real-

time" part.

Download Log Fi le

Click the [...] button next to the "Down Log File" in the Properties window, "Download Log File"

dialog box that appears, double-click to save the log file.

After setting the file name and path to save the file save dialog box by clicking the [Save]

button to save.

See also :

View Log - Realtime



Copyright ©  FORCS Co.,LTD. All rights reserved.

Tools
User Guide for OZ Enterprise Manager

50

Using the [Monitor Log] menu of console menu, setting the monitor log, checking saved

monitor log.

Click on the menu of the console [Monitor Log] > [Monitor Log Configuration] menu

Monitor log related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "monitor.properties" please.
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Click on the menu of the console [Monitor Log] > [View Monitor Log - Realtime] menu

If you click the Properties window from the [Start] button, the contents of the monitor log are

displayed in real-time.

Click on the menu of the console [Monitor Log] > [View Monitor Log - File] menu, verify the

monitor log contents of files stored or the monitor log file can be downloaded.

Open Log Fi le



Copyright ©  FORCS Co.,LTD. All rights reserved.

Tools
User Guide for OZ Enterprise Manager

52

Click the [...] button next to the "Open Log File" in the Properties window, "Open Log File"

dialog box that appears, double-click on the file to check the monitor logs.

In the selected file displays the stored log contents.
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Download Log Fi le

Click the [...] button next to the "Down Log File" in the Properties window, "Download Log File"

dialog box that appears, double-click to save the monitor log file.
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After setting the file name and path to save the file save dialog box by clicking the [Save]

button to save.
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This chapter describes how to set Scheduler server, Task, File manage, Log, Monitor log, etc, by

using OZ Enterprise Manager.
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Click the [New Scheduler] menu in a pop-up that appears after right-clicking on the Scheduler

list, run "New Scheduler" dialog box.

Fill the blanks in the "New Scheduler" dialog box and click on [Add], then the added

scheduler.
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To log in to the scheduler, open a pop-up menu by right clicking on the added scheduler

and click on [Connect].

After select the server to connect enter a user ID and password with admin rights in "OZ Server

Login" dialog box, When you click the [OK] button, the Scheduler, and OZ server is connected.

Scheduler and OZ server connection is completed, the scheduler can manage icons and menu

will be displayed in toolbar and console menu.
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[Management] in the console menu using the menu you can check Scheduler Information and

you can run License, Scheduler Configuration, HTML5MANAGER Configuration, Stop Scheduler,

Restart Scheduler.

Click on the menu of the console [Management] > [Scheduler Information] menu

Scheduler information related properties will be displayed in the Properties window.
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Click on the menu of the console [Management] > [License] menu

License related properties will be displayed in the Properties window.

Click on the menu of the console [Management] > [Scheduler Configuration] menu

Scheduler configuration related properties will be displayed in the Properties window.

If you want to change the scheduler behavior environment, double-click the value that you set

in the bottom of the Properties window, click the [Save] button to save, click the

[Management] > [Restart Scheduler] menu of console menu.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Scheduler

Administrator's Guide", "scheduler_server.properties" please.
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Click on the menu of the console [Management] > [HTML5MANAGER Configuration] menu

HTML5MANAGER configuration related properties will be displayed in the Properties window.

If you want to change HTML5MANAGER configuration, double-click the value that you set in the

bottom of the Properties window, click the [Save] button to save, click the [Management] >

[Restart Scheduler] menu of console menu.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Scheduler

Administrator's Guide", "html5manager.properties" please.

Click on the menu of the console [Management] > [Stop Scheduler] menu
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Displays a dialog box asking whether the scheduler stops.

When you click the [OK] button, the scheduler stop.

Click on the menu of the console [Management] > [Restart Scheduler] menu

Displays a dialog box asking whether the scheduler restarts.

When you click the [OK] button, the scheduler restart.
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[Task] in the console menu using the menu you can written in a sub-version of the task in the

current version, and converted to fit, check the task list, task result.

Click on the menu of the console [Task] > [Task Conversion] menu, show the conversion

options in the Properties window.

Set the file or directory where the converted OZS file will be saved either by selecting one in

the Select item dialog box that opens up after clicking on the [… ] button right of the current

version option or manually enter in the input window. Click on [Convert] after setting the lower

version and current version option and the selected lower version files will be converted into

ones for the current version in the set path.
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Click on the menu of the console [Task] > [Task Holiday Configuration] menu

The Task Holiday Group, added to the group Holidays is displayed in the Properties window.

Note :

To use the [Task Holiday Configuration] menu, the "TaskHoliday" property in the Scheduler

configuration window that appears after clicking on [Manage] > [Scheduler Configuration] in

the Menu bar must be set to "true".

For a detailed description of the properties shown in the Properties window, "OZ Enterprise

Server Administrator's Guide", "TaskHoliday.xml" please.
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See also :

Scheduler Configuration

New Task Holiday

After you click on "Task-Holiday" that Root of the holiday group representing in the Setting Task

Holiday window, by right-clicking on an empty area of the window list from the pop-up menu

that appears, click the [Add] menu settings dialog box holiday task execution.

"Setting Task Holiday" dialog box from the holiday's name, indicating the date of the holiday

standard formats, solar/lunar calendar, the kind that, when you click the [OK] button after you

enter your holiday start date, end date for the holidays The holidays will be added to the Root.

After the holidays add in the bottom of the Properties window, click the [Save] button.

Added Task Holiday to the Group

After you click the group, from the pop-up menu that appears by right-clicking on an empty area

of the Group Holidays List window run "Holiday" dialog box by clicking the [Add] menu.
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After checking From the group to be added to the holiday "Holiday" dialog box, click the [OK]

button. After the holidays add in the bottom of the Properties window, click the [Save] button.

Add Holiday Group

Root of the holiday group representing the "Task-Holiday" by right-clicking on the [Add] menu

in the pop-up menu that appears, run the "Add" dialog box.

After Enter the name of the group from the "Add" dialog box when you click the [OK] button,

the group is added to the holiday. After the Group Holidays addition is complete, click the

[Save] button in the bottom of the Properties window.
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Edit Task Holiday

That the Root of the holiday group by clicking on the "Task-Holiday" in the Setting Task Holiday

displays holiday list window. Right-click the task you want to modify holidays From the pop-up

menu that appears, click the [Modify] menu, run the "Setting Task Holiday" dialog box.

After you enter your holiday name, base format date, Solar/lunar calendar kind, holiday start

date, end date for the holidays in "Setting Task Holiday" dialog box, click the [OK] button. After

the holidays modify in the bottom of the Properties window, click the [Save] button.

Delete Task Holiday

That the Root group's holiday in Setting Task Holiday, click "Task-Holiday" window displays the

holiday list. Will display a dialog box asking whether to delete the menu, click [Delete] from the

pop-up menu that appears, delete by right-clicking on the task holidays.

Click the [OK] button, the task holidays will be deleted. After the holidays deleted in the

bottom of the Properties window, click the [Save] button.

Delete Holidays Added to the Task Group

By clicking on the group is added to the group that represents the holiday displays a window

list. Will display a dialog box asking whether to delete the menu, click [Delete] from the pop-up

menu that appears, delete by right-clicking on the task holidays.
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Click the [OK] button, the task holidays will be deleted. After the holidays deleted in the

bottom of the Properties window, click the [Save] button.

Click on the menu of the console [Task] > [Task List] menu

The Task List is displayed in the Properties window.

Task Name Task Name.

Task ID : Task ID.

Category : Item category of the file at which task is to be executed.

Item Name : Item file name.

Type : Schedule type of task

Once at specific time Periodically : Once at specific time

Periodically

Periodically : Periodically

Last Run Time : The time of the last task execution.

Next Run Time : The time of the next task execution.

Status : Task status.

PAUSE : PAUSE

RUN : RUN

WAITING : WAITING
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Click on the menu of the console [Task] > [Task List] menu, the Task List is displayed in the

Properties window. [Add] menu in the Task List window by clicking the right mouse button pop-

up menu that appears, add the Report Create Task, SDM Create Task, Print Create Task.

Report Create Task

OZ Reports designers made a report to export files in a variety of file formats such as PDF,

Word, Excel, JPG task. By changing the parameter values on export can be exported in various

forms.

SDM Create Task

SDM(Data Module) generate task on the large amounts of data or database server that a lot of

the load. Data Module generated by changing the parameter values can be generated in the

form of a variety, when the OZ viewer requests that data transfer SDM generated response

rate can be improved.

Print Create Task

Task is to print a report file created by OZ Reports designers. when printing a report by

changing the parameter values can be printed in various forms.

If Viewer that works with the scheduler type NONE  restrictions :

If Viewer type NONE and print create task  does not support, during Report create task

execution only OZD files can be exported.

Viewer type is  by clicking on the menu [Management] > [scheduler settings] in the Properties

window that appears can be found on the ViewType.
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Add a report create task by clicking on [Add] > [Add Report Create Task] in a pop-up that

opens up when right-clicking in the Task List window. Click on [Add] > [Add Report Create

Task] and the "Item Selection" dialog box will open up and the items of OZ report type

received from the server connected to the dialog box will show up. Now select items to add.

Clicking on [Next] will open up the "Task Option" dialog box.(FX parameter is only visible in a

report by adding FX data.)
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Set the [Parameter Information], [Export], [User defined processing] tab of "Task Option"

dialog box in the task execution options and click the [Next] button.
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After setting whether or not the e-mail sent, scheduled time on the [Send Email], [Scheduled

Time] tab and click the [Finish] button.

See also :

User defined processing,  Scheduled Time,  Export,  Send Email,  Parameter Information
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In the pop-up that opens up when right-clicking on the Task List window, click on [Add] >

[SDM Create Task] to add an SDM create task.

After selecting the ODI file to create a task in the "Item Selection" Click the [Next] button to

execute "Task Option" dialog box.
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Set the [Parameter Information], [Send Email], [Scheduled Time] tab of "Task Option" dialog

box and click the [Finish] button.

See also :

Scheduled Time,  Send Email,  Parameter Information
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In a pop-up that opens up when right-clicking on the Task List window, click on [Add] > [Print

Create Task] to add a print create task.

Clicking on [Add] > [Print Create Task] will open up the "Item Selection" dialog box which

shows the items of OZ Report. Clicking on [Next] will open up the "Task Option" dialog box.(FX

parameter is only visible in a report by adding FX data.)
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Set the [Parameter Information], [Print], [User defined processing] tab of "Task Option"

dialog and click the [Next] button.
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After setting whether or not the e-mail sent, scheduled time on the [Send Email], [Scheduled

Time] tab and click the [Finish] button.

Note :

If viewer type interact with the scheduler is NONE, Print create task does not support.

See also :
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User defined processing,  Scheduled Time,   Send Email,  Parameter Information,  Print

Edit Task

Open a pop-up menu by right-clicking on a task to edit in the Task List window, click on [Edit]

to open up the "Task Option" dialog box to edit the task.

After changing the option to move each tab and click the [Next], [Finish] button.
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Delete Task

Open a pop-up menu by right clicking on a task to delete in the Task List window and click on

[Delete] to delete the task.

Click on [OK].

View Result Task

Click on [View Result] in the pop-up that opens up when right-clicking on a task in the Task

List window. Clicking on [View Result] will show the task results in the Task List window.

Click [Save As] to save the task results to a file.

If there is an error message, right click on it and click [View Error] to read the details.

Set the options to be applied when you run the task such as Parameter Information, Export file

format, Pre/post-processing options, Send Email options, Scheduled time, Print options, etc.

Click on [Parameter Information] tab in "Task Option" dialog box set the form parameters and

he ODI parameter values.
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If the parameters have been added to the OZR, ODI file is automatically displayed in the input

parameters.

Click on [Export] tab in "Task Option" dialog box set the Report create task file save option.
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Note :

If the viewer type that works with the scheduler NONE, only OZD can be exported to a file.

More specific parameters for the file format, please see "The Oz Report Viewer help

developers" "viewer parameters" part of the description.
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Click on [User defined processing] tab in "Task Option" dialog box set the Pre/Post-processing

task program.

Pre-processing : Set to execute an external program before task execution.

Post-processing : Set up the program information to be executed after the task

execution completes normally.

Class name : Set the post processing class name. The class

name is set in the file scheduler_server.properties

direct input or can be set by the user-defined class,

the dialog box appears, click [...] button.
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User defined parameter : Sets the parameter name and value

when the post-processing program is executed to

apply.

Click on [Send Email] tab in "Task Option" dialog box  after  task was run set the mail

transmission whether and information.

Send email : Wether or not send email.
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Include HTML in contents : Include HTML in contents.

Notify recipient of error : Notify recipient of error

To : Email address of the recipient .

CC : Email address of the reference receiver.

BCC : Email address of the Bcc recipients

Subject : Mail subject.

Text : The main content of the mail.

Use HTML : Sets whether to send HTML mail body

content type.

Send Attached File in

Compressed Format(.ZIP) :

Sets whether or not sent by attachments compressed

into a single file.

File Name : File name Compressed Format.

When you click the [password] button that appears

the password dialog box using you can set a

password On the attachment.

Click on [Scheduled Time] tab in "Task Option" dialog box set the execution time of the task.
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Schedule Type : Task execution times.

Run immediately : Immediately after you create the task

execution.

Run once at fixed time : Set the period setup option in the

settings run once an hour.

Run periodically : Repeat the run cycle as set in the Setup Cycle

options.

Period Setup : Task execution period.

To prevent execution of a task for that date can be set using the

dialog box that appears, click the [Setting Task Holiday]  button.

Runtime : Task runtime.

Once a day : Once a day.
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Multiple times a day : Multiple times a day.

User define : The time entered in the text box.

Click on [Print] tab in "Task Option" dialog box set the execution option of the print create

task.

Note :
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More specific parameters for the print parameter, please see "The Oz Report Viewer help

developers" "viewer parameters" part of the description.

Start Task

Open a pop-up by right-clicking on a task in the Task List window and click on [Start] to start a

halted task.

Stop Task

Open a pop-up by right-clicking on a task in the Task List window and click on [Stop] to stop a

task.

Click on the menu of the console [Task] > [Task Result] menu

Run the "Scheduling Task Result" dialog box.
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Select date range : Whether to set up a query to set a start date and an end

date when the task result.

From : Start date.

To : End date.

Task ID : Task ID.

The results of the task is displayed in the Properties window when you click the [OK] button

after entering the date, task ID in "Scheduling Task Result" dialog box.

Click [Save As] to save the task results to a file.

If there is an error message, right click on it and click [View Error] to read the details.
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[File Management] in the console menu using the menu set the Exported file, External

program.

Click on the menu of the console [File Management] > [External Program] menu

Shows the external programs used when creating task.

Click on the menu of the console [File Management] > [Exported File] menu
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Shows the files exported to the Task Result.
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Using the [Log] menu of console menu, setting the log, checking saved log.

Click on the menu of the console [Log] > [Log Configuration] menu

Log related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Scheduler

Administrator's Guide", "scheduler_server_log.properties" please.
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Click on the menu of the console [Log] > [View Log - Realtime] menu

If you click the Properties window from the [Start] button, the contents of the log are displayed

in real-time.

To stop real-time view log, and click the [Stop] button, click the [Thread Dump] button to check

the thread dump.

Click the [Search] button after entering the text you want to search for in the text box next to

the search option to search the contents of the log. Order to retrieved content is displayed,

when you are double-click focusing searched the contents of the log.
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Click on the menu of the console [Log] > [View Log - File] menu, verify the log contents of

files stored or the log file can be downloaded.

Open Log Fi le

Click the [...] button next to the "Open Log File" in the Properties window, "Open Log File"

dialog box that appears, double-click on the file to check the logs.
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In the selected file displays the stored log contents.
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Open Log File from the contents can be searched, search method, please refer to the "log-real-

time" part.

Download Log Fi le

Click the [...] button next to the "Down Log File" in the Properties window, "Download Log File"

dialog box that appears, double-click to save the log file.

After setting the file name and path to save the file save dialog box by clicking the [Save]

button to save.

See also :

View Log - Realtime
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Using the [Monitor Log] menu of console menu, setting the monitor log, checking saved

monitor log.

Click on the menu of the console [Monitor Log] > [Monitor Log Configuration] menu

Monitor log related properties will be displayed in the Properties window.

To change the value of the property, double-click the value that is set in the bottom of the

Properties window, click the [Save] button.

Note :

For a detailed description of the properties shown in the Properties window, "OZ Scheduler

Administrator's Guide", "scheduler_server_log.properties" please.
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Click on the menu of the console [Monitor Log] > [View Monitor Log - Realtime] menu

If you click the Properties window from the [Start] button, the contents of the monitor log are

displayed in real-time.

Click on the menu of the console [Monitor Log] > [View Monitor Log - File] menu, verify the

monitor log contents of files stored or the monitor log file can be downloaded.

Open Log Fi le
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Click the [...] button next to the "Open Log File" in the Properties window, "Open Log File"

dialog box that appears, double-click on the file to check the monitor logs.

In the selected file displays the stored log contents.

Download Log Fi le

Click the [...] button next to the "Down Log File" in the Properties window, "Download Log File"

dialog box that appears, double-click to save the monitor log file.
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After setting the file name and path to save the file save dialog box by clicking the [Save]

button to save.


	User Guide for OZ Enterprise Manager
	Table of Contents
	OZ Server Management and Configuration
	New Server
	New Server Dialog Box

	Login Server
	Server Management
	Server Information
	Server License
	Memory Status
	Memory Collection
	Stop Server
	Restart Server

	Repository
	Repository Configuration
	Reload Repository

	Cache
	Cache Configuration
	Cache List
	Cache Add
	Cache Information Dialog Box
	Cache ID Wizard


	Cache Edit, Delete, Delete Data


	Connection
	DB Connection Pool
	Add DB Connection Pool
	DB Connection Pool Dialog Box

	Edit, Delete DB Connection Pool

	SAP Connection Pool

	Server Properties
	Databind Configuration
	User Defined Log Configuration
	Data Source Configuration
	Add Data Source
	Add Data Source Dialog Box

	Edit, Delete Data Source

	User Security Logic Configuration
	Mail Config
	Add Mail Config
	Add Mail Config Dialog Box

	Edit, Delete Mail Config

	Information Security Configuration
	HTML5MANAGER Configuration
	Add HTML5MANAGER
	Add HTML5MANAGER Dialog Box

	Edit, Delete HTML5MANAGER


	Log
	Log Configuration
	View Log - Realtime
	View Log - File

	Monitor Log
	Monitor Log Configuration
	View Monitor Log - Realtime
	View Monitor Log - File


	OZ Scheduler Management and Configuration
	New Scheduler
	Login Scheduler
	Scheduler Management
	Scheduler Information
	License
	Scheduler Configuration
	HTML5MANAGER Configuration
	Stop Scheduler
	Restart Scheduler

	Task
	Task Conversion
	Task Holiday Configuration
	Add Task Holiday, Group
	Edit, Delete Task Holiday

	Task List
	Add Task
	Report Create Task
	SDM Create Task
	Print Create Task

	Edit, Delete, View Result Task
	Task Option
	Parameter Information
	Export
	User defined processing
	Send Email
	Scheduled Time
	Print

	Start, Stop Task

	Task Result

	File Management
	External Program
	Exported File

	Log
	Log Configuration
	View Log - Realtime
	View Log - File

	Monitor Log
	Monitor Log Configuration
	View Monitor Log - Realtime
	View Monitor Log - File



